Changes between Version 2 and Version 3 of python-rtmidi/install


Ignore:
Timestamp:
11/05/2013 07:36:45 PM (7 years ago)
Author:
carndt
Comment:

Fill placeholders

Legend:

Unmodified
Added
Removed
Modified
  • python-rtmidi/install

    v2 v3  
    11{{{ 
    22#!rst 
     3 
     4.. contents::   
     5    :depth: 2  
     6 
    37Installation 
    48============ 
    5  
    6 .. contents::  
    7     :depth: 2 
    8  
    99 
    1010**python-rtmidi** uses the de-facto standard Python distutils and setuptools_ 
     
    5353commands, e.g.:: 
    5454 
    55     $ wget %(download_url)spython-rtmidi-%(version)s.tar.gz 
    56     $ tar -xzf python-rtmidi-%(version)s.tar.gz 
    57     $ cd python-rtmidi-%(version)s 
     55    $ wget http://chrisarndt.de/projects/python-rtmidi/download/python-rtmidi-0.4b.tar.gz 
     56    $ tar -xzf python-rtmidi-0.4b.tar.gz 
     57    $ cd python-rtmidi-0.4b 
    5858    $ python setup.py install 
    5959 
     
    9090Install **python-rtmidi**:: 
    9191 
    92     (rtmidi)$ svn co %(repository)s python-rtmidi 
     92    (rtmidi)$ svn co svn://svn.chrisarndt.de/projects/python-rtmidi/trunk python-rtmidi 
    9393    (rtmidi)$ cd python-rtmidi 
    9494    (rtmidi)$ python setup.py install 
     
    103103Only if you want to change the Cython source file ``_rtmidi.pyx`` or want to 
    104104recompile ``_rtmidi.cpp`` with a newer Cython version, you'll need to install 
    105 Cython >= 0.17. The ``_rtmidi.cpp`` file in the  source distribution was 
    106 generated with Cython 0.18pre as of 2013-01-14 and Python 2.7.3. 
     105Cython >= 0.17. The ``_rtmidi.cpp`` file in the current source distribution 
     106(version 0.4b was generated with Cython 0.18pre as of 2013-11-05 16:59 
     107and Python 2.7.3. 
    107108 
    108109RtMidi (and therefore **python-rtmidi**) supports several low-level MIDI